Partial Outage - Some paid accounts defaulting to billing screen

Incident Report for Tettra

Resolved

We have restored access to all the affected accounts and are monitoring the situation.
Posted Apr 19, 2024 - 11:16 EDT

Identified

We have identified the issue with our billing system that is blocking some paid teams from accessing their customers. We are currently in the process of fixing it.
Posted Apr 19, 2024 - 10:14 EDT

Investigating

We are investigating an issue with our billing system that is defaulting some paid teams to the billing page.
Posted Apr 19, 2024 - 10:13 EDT
This incident affected: app.tettra.co.