Heroku server issues

Incident Report for Tettra

Resolved

We have been able to identify the issue caused by heroku, and make a work around to get tettra accessible once again
Posted Jun 10, 2025 - 22:52 EDT

Identified

We are experience server issues with our hosting service Heroku (Salesforce). We are actively investigating the issue, and will update as soon as we have identified the issue. Customers will have issues logging in and using Tettra.
Posted Jun 10, 2025 - 22:34 EDT
This incident affected: app.tettra.co.